jose-util
Implementation of JOSE standards (JWE, JWS, JWT) in Go (program)
Command lineDevelopment
Not tested on a device yet. What that means
Commands in the package
jose-util
About jose-util
From Debian's package description
go-jose aims to provide an implementation of the Javascript Object Signing and Encryption set of standards. This includes support for JSON Web Encryption, JSON Web Signature, and JSON Web Token standards.
The implementation follows the JSON Web Encryption (http://dx.doi.org/10.17487/RFC7516) (RFC 7516), JSON Web Signature (http://dx.doi.org/10.17487/RFC7515) (RFC 7515), and JSON Web Token (http://dx.doi.org/10.17487/RFC7519) (RFC 7519) specifications. Tables of supported algorithms are shown below. The library supports both the compact and JWS/JWE JSON Serialization formats, and has optional support for multiple recipients. It also comes with a small command-line utility (jose-util (https://github.com/go-jose/go-jose/tree/master/jose-util)) for dealing with JOSE messages in a shell.
This package contains the `jose-util` command line tool.
From Debian's description of the jose-util package, under that package's license.
Dependencies
Depends on
libc6
Related apps
- automakeTool for generating GNU Standards-compliant MakefilesCommand line
- llvm-22-toolsModular compiler and toolchain technologies, toolsCommand line
- dh-nodejsdebhelper addon to build Node.js modulesCommand line
- jwtgolang implementation of JSON Web Tokens (command line)Command line
- zlintX.509 Certificate Linter focused on Web PKI standards (program)Command line
- rnbycJWK and JWT parser and generatorCommand line
Sources and licenses
- Name: the Debian package name.
- Summary: Debian's short description of the jose-util package, under that package's license.
- Description: Debian's description of the jose-util package, under that package's license.
- Versions and sizes: Debian's archive for ARM64, as on packages.debian.org.
- Popularity: Debian Popularity Contest counts.
More in About the catalog.